Published on February 18, 2020 By JanOscar In Forum Issues

When trying to access forums via Wincustomize, I have been getting this page (screenshot) for the last days.
Happens with all the big browsers (Google Chrome, Firefox, Edge & Opera). This happens only when I'm logged in and clearing cookies & logging out gets me to the Wincustomize forums, but as soon as attempting to log in, I get the screen above. Not a big deal, since I can access the forums at forums.stardock.com. Microsoft Edge is 100% unmodified, so no blockers or plugins are causing this.

Microsoft Edge
 
Microsoft Edge is up to date.Version 80.0.361.54 (Official build) (64-bit)

Comments (Page 2)
2 Pages1 2 
on Feb 18, 2020

LightStar

I don't think Stardock has no control over that, I think it's your country doing it.
Or more than likely, the third party, FastSpring, that handles the transactions for Stardock. They are the ones changing the currency for me to €uro and there is clearly no need for that when using PayPal other than FastSpring charging an exchange fee.

on Feb 18, 2020

I couldn't check status yay or nay in Oz....was asleep....missed it all...

on Feb 19, 2020


Or more than likely, the third party, FastSpring, that handles the transactions for Stardock. They are the ones changing the currency for me to €uro and there is clearly no need for that when using PayPal other than FastSpring charging an exchange fee.

Sales between USA and many other countries (mostly EU) required that a Value-Added Tax (VAT) be collected.  We had not been collecting them in the past but we are required to do so.  Because of the high costs of administering VAT and other reasons is why we switched over to using FastSpring to facilating our sales.

So, with VAT, State Sales Tax and Currency Exchange rates, the prices will vary from Country to Country and State to State.

2 Pages1 2